Back to overview
Downtime
All services are down.
Sep 20 at 10:43am HDT
Affected services
cloud.futruolabs.com
Photos
Resolved
Sep 20 at 11:14am HDT
It appears as though our connection has stabilized, we will continue to monitor the connection.
Affected services
Created
Sep 20 at 10:43am HDT
Hi there, we are having some issues with our Internet service provider(ISP) at our main server's location. Mail and Minecraft are unaffected. Current resolution ETA is 4pm PST, thank you for understanding.
Affected services